Je tam tak jako tak, aby instalace Twain modul Pythonu 3

hlasů
1

Chci nainstalovat modul Python TWAIN Python 3. Ale v docs se píše:

Python verze 2.1 až 2.5 jsou podporovány.

Mohu převést jej pomocí 2to3?

Položena 12/01/2016 v 13:06
uživatelem
V jiných jazycích...                            


1 odpovědí

hlasů
0

Použít dřívější modul, který poskytuje experimentální překlad balíček na pomoc s dovozem a použitím starých modulů Python 2 v Python 3 prostředí.

Takže nainstalovat balíček s pip

pip3 install twain --no-compile   # to ignore SyntaxErrors

A použít další kód pro import TWAIN ve svém python3kódu:

from past import autotranslate
autotranslate(['twain'])

import twain


# use twain ....... 
Odpovězeno 12/01/2016 v 13:13
zdroj uživatelem

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more